neogeo system
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment : -60%
-60% : 2 briques de rangement empilables LEGO à ...
Voir le deal
19.99 €

Problème NeoGeo AES

4 participants

Aller en bas

Problème NeoGeo AES Empty Problème NeoGeo AES

Message  Baboulinet Ven 5 Juil 2024 - 17:32

Bonjour tout le monde,

Je viens solliciter votre expertise : j'ai voulu me faire une petite séance de NeoGeo, cela faisait plusieurs mois que je n'avais pas touché à la bête (monde de merde!).
Du coup je lance un jeu : ça fonctionne normalement mais j'ai des bugs de sons in game (générique NeoGeo OK).
Par exemple dans AOF2, le speach de Yuri est normal mais les musiques en jeu étaient dégueux).
Je fais plusieurs reboot, enlevage de cartouche... mais rien n'y a fait, soit c'était pire niveau sonore mais je n'ai pas eu le son normal.
Enfin, après plusieurs reboot, j'obtiens une bouillie de pixels sur un fond noir et le son qui saute (sans musique sans rien):
Avec jeu:

Lorsque je boote la console sans jeu, j'obtiens un écran vert qui saute :
Sans jeu:
J'ai acheté un Neo Diag entre temps que j'ai monté sur le support tulipe et obtiens le même résultat : écran vert qui saute avec des pixels sans jeu...

J'ai vu que l'écran vert est associé à la "color RAM error", cependant comme l'écran n'est pas figé et qu'il y a eu des problèmes sonores auparavant, j'aimerais avoir votre avis svp. Smile
Je suis équipé d'un multimètre et peux faire des tests; seul bémol : je suis novice en électronique, donc si vous avez des tutos à partager, je suis preneur!  Wink

D'avance, merci pour votre aide, en espérant pouvoir ressusciter la belle! Cool

Configuration :
Console : NeoGeo AES 3-4
Bios : Unibios v3.3 sur support tulipe
Alimentation : 9V ; 5A


Dernière édition par Baboulinet le Sam 6 Juil 2024 - 11:12, édité 1 fois
Baboulinet
Baboulinet
330 Mega Shock
330 Mega Shock

Messages : 338
Date d'inscription : 10/10/2017
Localisation : 07

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  illusionrip Ven 5 Juil 2024 - 20:02

essaye de nettoyer tes connecteurs avec de l'alcool iso propylique

si ca marche toujours pas alors il pourrait s'agir du Neo-C1 qui a claqué
pas grand chose a faire aujourd'hui
il gere le decodage d'adresse de la rom programme de la cartouche, mais aussi sur la partie son

si le son était en décalage ca pouvait être les premiers symptômes de la mort du Neo-C1
c'est une puce propriétaire, la seule solution aujourd'hui c'est d'en extraire une sur un slot MVS

avec un pote on bosse sur une puce programmable de remplacement, mais ca va prendre du temps
illusionrip
illusionrip
Adepte du stick
Adepte du stick

Système(s) : AES jap et us en boite
Messages : 285
Date d'inscription : 11/01/2015
Age : 50
Localisation : pologne

nic034 et Baboulinet aiment ce message

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  nic034 Ven 5 Juil 2024 - 20:17

Hello

Mon avis personnel, corrigez moi les mecs si je fais fausse route.

Pour le neo-c1, pas d’expérience sur les symptômes de la panne (je n’ai pas eu ce chip hs encore) mais je me calle sur l’avis d’Illusionrip qui connaît ce sujet. si tu as un peu de matériel, tu devrais inspecter ce chip et notamment son raccordement afin de s’assurer qu’il joue bien son rôle, personnellement je le retirerai proprement et je checkerai le pinout complet avec le schéma à jour.

Tu peux faire un test sans cartouche et me donner le retour couleur de ton écran ? Partant du principe où ton alimentation est ok, et ton port cartouche est propre et nettoyé à fond : Il faudrait faire une inspection de la carte autour des ouvertures et notamment côté ram, fast ram, lspc2 et 2610, neo-c1

Pour le son : si c’est pas le Neo-c1, tu as sûrement des pistes coupés entre le YM2610/port cartouche et/ou autour du YM2610 pour la partie son ce qui explique en partie le manque de certain flux audio . Si le YM2610 ne communiquai pas avec le z80, tu aurai un écran noir avec un clic régulier. La partie audio est sur le côté droit de chaque slot quand tu as la console en face de toi, il te faudrait le « touchetonpin’3000 » de notre ami Illusionrip (merci à lui), les schéma en 3-5 format PDF, un testeur de continuité et du temps. Ma solution : je retire le YM2610, inspection visuelle au microscope, touchetonpin3000 entre le YM2610 et le port cartouche etc..

la bouillie verte, si c’est pas le Neo-c1, ça peut être pas mal de chose : la ram video ou fast ram hs, problème de piste coupé côté ram video/fast ram video (gros doute), lspc2 mal soudé, problème de piste vers le lspc2, problème de piste depuis le port cartouche etc.. ma solution : inspection visuelle en haut à droite de la carte mère, lspc2, fast ram video, ram video, port cartouche, reflow lspc2, touchetonpin3000 entre le lspc2 et la ram video / fast ram video, port cartouche, continuité port cartouche lspc2 etc..

À mon avis ta console commence à souffrir de pistes oxydées ou coupés, ou as des chip ko.
quel a été la méthode d’entreposage et à quelle température ?

A+
nic034
nic034
1000 Mega Shock
1000 Mega Shock

Messages : 2833
Date d'inscription : 03/01/2016
Age : 45
Localisation : Montpellier

Baboulinet aime ce message

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  Elta Sam 6 Juil 2024 - 1:06

C'est moi ou il y a de plus en plus souvent du matos qui tombe en panne ? Nos bonnes vieilles machines arriveraient-elles pour de bon à la limite de leur durée de vie ? On en parle depuis des années déjà mais là je commence à m'inquiéter Crying or Very sad
Elta
Elta
Adepte du stick
Adepte du stick

Messages : 214
Date d'inscription : 14/06/2021
Age : 45
Localisation : 94

Baboulinet n'aime pas ce message

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  nic034 Sam 6 Juil 2024 - 1:41

Yen a une grosse partie qui commence oui, mais la plupart sont attaqués pas la corrosion..
Le problème reste les puces custom..
nic034
nic034
1000 Mega Shock
1000 Mega Shock

Messages : 2833
Date d'inscription : 03/01/2016
Age : 45
Localisation : Montpellier

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  Elta Sam 6 Juil 2024 - 3:03

nic034 a écrit:Yen a une grosse partie qui commence oui, mais la plupart sont attaqués pas la corrosion..
Le problème reste les puces custom..

Si le principal problème c'est la corrosion on peut la retarder en entreposant dans de bonnes conditions je suppose.
Les puces customs ? Parce qu'elles sont introuvables sauf à cannibaliser je suppose ?
Elta
Elta
Adepte du stick
Adepte du stick

Messages : 214
Date d'inscription : 14/06/2021
Age : 45
Localisation : 94

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  illusionrip Sam 6 Juil 2024 - 7:17

entreposer maintenant ne sert pas a grand chose, ca prend des années pour qu cela corrosion s'installe, et a dut leur faire sournoisement depuis des années sur pas mal de nos consoles.
reste plus que l'intervention chirurgical au moment de la panne

en ce qui concerne les customs, les plus faciles ont ete refait par furrtek, mais les plus compliques non
ce n'est pas que ce n'est possible, mais juste une question de prix final
par exemple le Neo-C& sur lequel nous bossons sera certainement vers les 30-40e
on est oblige de passer sur un support flex qui coute chère, et en plus la puce programmable que l'on veut utilisé n'est pas donne, sans compter le montage a la mano d'une puce 100 broches

pour ta console, si elle fait un clique, il ne peut y avoir qu'un ensemble de puce en cause, celle qui communique entre elle sur un bus commun d'adresse et de données:
-Neo-Po (bios)
-Neo-E1
-Neo-D0
-Neo-C1
-Neo-G0
-LSPC2-A2
-Neo-B1
-HC259 (juste au dessus du bios)
-68000
-Puces Wram
-port cartouche haut

je crois que j'ai rien oublie

si t'as une piste de couples entre le Z80 et le YM2610, tu devrais pas avoir ca sur l'écran, juste plus de son, ou un son merdique, mais ca rentrerait pas en conflit avec l'affichage
illusionrip
illusionrip
Adepte du stick
Adepte du stick

Système(s) : AES jap et us en boite
Messages : 285
Date d'inscription : 11/01/2015
Age : 50
Localisation : pologne

Baboulinet aime ce message

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  Baboulinet Sam 6 Juil 2024 - 11:15

illusionrip a écrit:essaye de nettoyer tes connecteurs avec de l'alcool iso propylique

si ca marche toujours pas alors il pourrait s'agir du Neo-C1 qui a claqué
pas grand chose a faire aujourd'hui
il gere le decodage d'adresse de la rom programme de la cartouche, mais aussi sur la partie son

si le son était en décalage ca pouvait être les premiers symptômes de la mort du Neo-C1
c'est une puce propriétaire, la seule solution aujourd'hui c'est d'en extraire une sur un slot MVS

avec un pote on bosse sur une puce programmable de remplacement, mais ca va prendre du temps

Merci pour ton retour, je vais commander de l'alcool isopropylique et passer un coup sur les contacteurs; je vous tiens au courant! Wink
Baboulinet
Baboulinet
330 Mega Shock
330 Mega Shock

Messages : 338
Date d'inscription : 10/10/2017
Localisation : 07

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  Baboulinet Sam 6 Juil 2024 - 11:31

nic034 a écrit:Hello

Mon avis personnel, corrigez moi les mecs si je fais fausse route.

Pour le neo-c1, pas d’expérience sur les symptômes de la panne (je n’ai pas eu ce chip hs encore) mais je me calle sur l’avis d’Illusionrip qui connaît ce sujet. si tu as un peu de matériel, tu devrais inspecter ce chip et notamment son raccordement afin de s’assurer qu’il joue bien son rôle, personnellement je le retirerai proprement et je checkerai le pinout complet avec le schéma à jour.

Tu peux faire un test sans cartouche et me donner le retour couleur de ton écran ? Partant du principe où ton alimentation est ok, et ton port cartouche est propre et nettoyé à fond : Il faudrait faire une inspection de la carte autour des ouvertures et notamment côté ram, fast ram, lspc2 et 2610, neo-c1

Je viens d'éditer mon premier message pour être plus clair :
- Avec jeu : bouillie de pixels sur fond noir avec écran qui saute
- Sans jeu : bouillie de pixels sur fond vert avec écran qui saute
L'alimentation a fonctionné pendant plusieurs années donc je pense que soit elle serait morte : ne s'allume pas du tout, sinon c'est que ça fonctionne, non?
Je vais effectivement commencer par nettoyer le port cartouche avec de l'alcool isopropylique pour voir ce que ça donne Smile

nic034 a écrit:
Pour le son : si c’est pas le Neo-c1, tu as sûrement des pistes coupés entre le YM2610/port cartouche et/ou autour du YM2610 pour la partie son ce qui explique en partie le manque de certain flux audio . Si le YM2610 ne communiquai pas avec le z80, tu aurai un écran noir avec un clic régulier. La partie audio est sur le côté droit de chaque slot quand tu as la console en face de toi, il te faudrait le « touchetonpin’3000 » de notre ami Illusionrip (merci à lui), les schéma en 3-5 format PDF, un testeur de continuité et du temps. Ma solution : je retire le YM2610, inspection visuelle au microscope, touchetonpin3000 entre le YM2610 et le port cartouche etc..

C'est probable comme l'écran est noir et que ça saute, ça fait un "tac-tac" régulier : c'est possible de faire des contrôles avec un multimètre? Est-ce qu'il y a un schéma des pistes à vérifier stp?

nic034 a écrit:
la bouillie verte, si c’est pas le Neo-c1, ça peut être pas mal de chose : la ram video ou fast ram hs, problème de piste coupé côté ram video/fast ram video (gros doute), lspc2 mal soudé, problème de piste vers le lspc2, problème de piste depuis le port cartouche etc.. ma solution : inspection visuelle en haut à droite de la carte mère, lspc2, fast ram video, ram video, port cartouche, reflow lspc2, touchetonpin3000 entre le lspc2 et la ram video / fast ram video, port cartouche, continuité port cartouche lspc2 etc..

À mon avis ta console commence à souffrir de pistes oxydées ou coupés, ou as des chip ko.
quel a été la méthode d’entreposage et à quelle température ?

A+

Ce sera aussi à regarder par la suite, sinon la console était dans une chambre, température ambiante : environ 20-25°C et pas d'humidité ou quoi que ce soit donc pas de raison qu'elle se dégrade à priori...

Merci pour ton retour! Very Happy
Baboulinet
Baboulinet
330 Mega Shock
330 Mega Shock

Messages : 338
Date d'inscription : 10/10/2017
Localisation : 07

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  nic034 Sam 6 Juil 2024 - 12:28

nic034
nic034
1000 Mega Shock
1000 Mega Shock

Messages : 2833
Date d'inscription : 03/01/2016
Age : 45
Localisation : Montpellier

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  Baboulinet Sam 6 Juil 2024 - 12:45

Merci beaucoup! Very Happy
Est-ce qu'il y a des différences entre la 3.4 (la mienne) et la 3.5 (celle dont tu m'as donné le schéma)?
Baboulinet
Baboulinet
330 Mega Shock
330 Mega Shock

Messages : 338
Date d'inscription : 10/10/2017
Localisation : 07

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  illusionrip Sam 6 Juil 2024 - 13:05

Par contre si ça cliquete tout le temps , oublie le nettoyage du port cartouche
C’est un problème plus sérieux
illusionrip
illusionrip
Adepte du stick
Adepte du stick

Système(s) : AES jap et us en boite
Messages : 285
Date d'inscription : 11/01/2015
Age : 50
Localisation : pologne

nic034 aime ce message

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  nic034 Sam 6 Juil 2024 - 13:25

Baboulinet a écrit:Merci beaucoup! Very Happy
Est-ce qu'il y a des différences entre la 3.4 (la mienne) et la 3.5 (celle dont tu m'as donné le schéma)?

Non c’est quif-quif tu peux t’y référer
Je l’ai pour ma part imprimé et je stabilote les lignes vérifiés
Dans ton cas, toute la partie video et son est à vérifier.
nic034
nic034
1000 Mega Shock
1000 Mega Shock

Messages : 2833
Date d'inscription : 03/01/2016
Age : 45
Localisation : Montpellier

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  illusionrip Sam 6 Juil 2024 - 16:44

utilises la photo en pieces jointes
la reference c'est le bios, et tu testes chaque ligne du bios avec les pin correspondant des différents chips

Problème NeoGeo AES Captur22
illusionrip
illusionrip
Adepte du stick
Adepte du stick

Système(s) : AES jap et us en boite
Messages : 285
Date d'inscription : 11/01/2015
Age : 50
Localisation : pologne

nic034 aime ce message

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  Baboulinet Dim 7 Juil 2024 - 16:44

Merci encore les gars, je ne peux malheureusement pas m'en occuper dans l'immédiat mais je vous tiendrai informé! 😉
Baboulinet
Baboulinet
330 Mega Shock
330 Mega Shock

Messages : 338
Date d'inscription : 10/10/2017
Localisation : 07

Revenir en haut Aller en bas

Problème NeoGeo AES Empty Re: Problème NeoGeo AES

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum