MVS en panne

Page 1 sur 2 1, 2  Suivant

Aller en bas

MVS en panne Empty MVS en panne

Message  Enskynet Ven 12 Fév 2021 - 13:22

Salut à tous !

Je me suis procuré un petit lots de jeux HS pour faire mes armes dessus et il y en a un dans le lot que j'aimerai sauver.
C'est un shock troopers assez propre.

Comme j'ai déjà ce jeu, j'ai fait un test croisé des PCB.

Donc le PCB 2 fonctionne nickel avec mon PCB 1.
Sur le PCB 1 du jeu HS, il y a une EEPROM, et je pense que le problème vient de la.

Pour les symptômes, le jeu se lance, je vois l'écran titre puis, dès qu'on met un crédit, le jeu reboot.

Voici ma question:
Je vais dessouder l'EEPROM 27C800 du mvs en panne pour lui remettre une ROM propre.
Si jamais cela ne fonctionne pas, comment je peux faire pour lire mes puces de ma cartouche legit sans les dessouder? Car j'aimerai ne pas tuer mon shock troopers fonctionnel.
Peut-etre est il possible de dessouder les puces du jeux HS une par une et tester l’intégrité du code par rapport aux roms sur internet?

Merci !
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Ryo Sakazaki Ven 12 Fév 2021 - 14:04

Enskynet a écrit:Je vais dessouder l'EEPROM 27C800 du mvs en panne pour lui remettre une ROM propre.
Si jamais cela ne fonctionne pas, comment je peux faire pour lire mes puces de ma cartouche legit sans les dessouder? Car j'aimerai ne pas tuer mon shock troopers fonctionnel.
Peut-etre est il possible de dessouder les puces du jeux HS une par une et tester l’intégrité du code par rapport aux roms sur internet?

Merci !

Déjà si tu en as un tu peux mettre un support tulipe cela évite de faire chauffer les pattes de l'eprom plusieus fois pour rien, en plus si tu fais ça avec un fer à souder classique qui est alimenté en 230V direct tu peux risque de flinguer l'eprom c'est pour cela que les stations de soudure ont leur fer à souder qui fonctionne avec une petite tension qui ne fait aucun dommage aux composants électronique.

Pour savoir si ton ou tes eproms sont HS ou pas tu peux les dessouder, ensuite les placer sur un programmateur et les comparer par rapport à un fichier de rom (avec le CRC vérifié) pour être sur que tu as le même fichier sur l'eprom et la rom.

Si tu dessoudes tes eproms et que tu me les envoi je pourrais te dire laquelle est HS. Cool



_________________
MVS en panne 449214ryo2
_________________
MVS en panne 894779697231userbar

Administrateur sur Neo-Geo System

Je réalise des converts AES/MVS, programmation d'eproms, bios, etc...
Ryo Sakazaki
Ryo Sakazaki
Admin

Système(s) : AES Jap, MVS MV-2F
Messages : 14982
Date d'inscription : 15/10/2011
Age : 46
Localisation : Dept 91

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Ven 12 Fév 2021 - 14:26

Merci Ryo pour ta réponse et ta proposition.
J'ai acheté consciemment ces mvs pour essayer de les reparer moi-même.
Je vais donc tester les eprom une par une.

Pour le fer a souder c'est pas qu'une question de temperature donc ?!
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Ryo Sakazaki Ven 12 Fév 2021 - 14:36

Enskynet a écrit:Merci Ryo pour ta réponse et ta proposition.
J'ai acheté consciemment ces mvs pour essayer de les reparer moi-même.
Je vais donc tester les eprom une par une.

Pour le fer a souder c'est pas qu'une question de temperature donc ?!

Non mais il ne faut pas chauffer trop longtemps une patte d'eprom sinon tu peux aussi la rendre HS.

As tu un programmateur d'eprom ?

_________________
MVS en panne 449214ryo2
_________________
MVS en panne 894779697231userbar

Administrateur sur Neo-Geo System

Je réalise des converts AES/MVS, programmation d'eproms, bios, etc...
Ryo Sakazaki
Ryo Sakazaki
Admin

Système(s) : AES Jap, MVS MV-2F
Messages : 14982
Date d'inscription : 15/10/2011
Age : 46
Localisation : Dept 91

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Ven 12 Fév 2021 - 15:20

On va m'en passer un ce week-end
Pour la soudure je regle toujours environ a 350° et je laisse maximum 1 demi seconde et la soudure fond nickel
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Ryo Sakazaki Ven 12 Fév 2021 - 15:50

Enskynet a écrit:On va m'en passer un ce week-end
Pour la soudure je regle toujours environ a 350° et je laisse maximum 1 demi seconde et la soudure fond nickel

Oui pas plus haut c'est bon. Wink

_________________
MVS en panne 449214ryo2
_________________
MVS en panne 894779697231userbar

Administrateur sur Neo-Geo System

Je réalise des converts AES/MVS, programmation d'eproms, bios, etc...
Ryo Sakazaki
Ryo Sakazaki
Admin

Système(s) : AES Jap, MVS MV-2F
Messages : 14982
Date d'inscription : 15/10/2011
Age : 46
Localisation : Dept 91

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Ven 12 Fév 2021 - 17:52

Nickel merci !
Je teste tout ça dès que j'ai le programmateur en main et je reviens ici.

C'est assez basique le MVS au final. J'ai une formation en électronique et je pensais que c'était plus complexe.

Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Ptchnk Ven 12 Fév 2021 - 20:51

Salut,

Tu parles d'une 27C800, donc c'est probablement la P1 dont tu parles (reboot dès le début du jeu). Un souci sur cette rom peut effectivement causer de pb de reboot. Comme tu le proposais, regarde celle-ci d'abord et remplace la par une eprom vérifiée.

Le programme n'est que sur les roms P, les roms V sont justes pour les samples du jeu et ne causent pas ce genre de bugs. La V1 serait un peu plus complexe a vérifier car c'est une 32Mbits en 8bit.

La carte avait déjà subit une réparation, ou du moins une tentative.
Ptchnk
Ptchnk
Adepte du stick
Adepte du stick

Système(s) : MVS, Coregrafx, PCE-DUO, RPI2J
Messages : 140
Date d'inscription : 04/05/2020
Age : 42

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Sam 13 Fév 2021 - 1:18

C'est ce que j'ai pensé, comme toi, pour la réparation.

Tout est original sur les 2 cartes, sauf la P1.
Les connectivités sont OK. J'ai refait toutes les soudures des 2 cartes proprement.

Par logique et élimination je pense que la 27c800 sur le P1 est défectueuse / déprogrammée / a été programmée sans un check CRC après programmation.
Théoriquement je récupère le programmateur demain. Il me faudrait juste un effaceur d'EEPROM mais Amazon est mon meilleur ami.

Keep in touch
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Jeu 18 Fév 2021 - 17:25

Je continue ici dans un soucis de ne pas polluer la section en re faisant un nouveau post.

J'ai pas encore reçu mon GQ 4X, uniquement l'effaceur d'EEPROM.

Cependant, j'ai une autre question concernant un autre jeu toujours en MVS.

Cette fois le jeu est un original 100%
Quand je mets la cartouche correctement dans le slot, j'ai un écran Crosshatch ou un bug graphique. Cependant, quand j'insère la cartouche à mi-course uniquement, le jeu fonctionne nickel !! (J'ai eu que 1 seule fois un ecran avec les adresses mémoire en vert sur une session de 1h de jeu. Après redémarrage, nickel).

Pour vous ce symptome est dû à des pistes sales? Je les ai nettoyées avec une gomme blanche et elles sont bien brillantes.
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  kazki Jeu 18 Fév 2021 - 18:10

tente un nettoyage du connecteur cartouche du slot

feuille de papier pliée en 2, on met une carte de fidélité entre les 2 couches, on asperge du nettoyant contact ou de l'alcool iso et on insère le tout bien verticalement sur toute la largeur Smile

Enskynet a écrit:Je continue ici dans un soucis de ne pas polluer la section en re faisant un nouveau post.

J'ai pas encore reçu mon GQ 4X, uniquement l'effaceur d'EEPROM.

Cependant, j'ai une autre question concernant un autre jeu toujours en MVS.

Cette fois le jeu est un original 100%
Quand je mets la cartouche correctement dans le slot, j'ai un écran Crosshatch ou un bug graphique. Cependant, quand j'insère la cartouche à mi-course uniquement, le jeu fonctionne nickel !! (J'ai eu que 1 seule fois un ecran avec les adresses mémoire en vert sur une session de 1h de jeu. Après redémarrage, nickel).

Pour vous ce symptome est dû à des pistes sales? Je les ai nettoyées avec une gomme blanche et elles sont bien brillantes.
kazki
kazki
1000 Mega Shock
1000 Mega Shock

Système(s) : AES MVS PGM CPS2 NAOMI
Messages : 5790
Date d'inscription : 22/10/2018

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Jeu 18 Fév 2021 - 19:27

Déjà fait coté slot + pâte à prout (Je suis un bon élève du forum, je me renseigne bien même sur les posts qui datent de 2008 mrgreen )

Je suis sur le PCB la. J'ai pas gommé assez fort. Je lui remet un coup de Isopropyl + gomme blanche et je re teste.
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  kazki Jeu 18 Fév 2021 - 19:51

toutafé

j'ai un slot mv1fz et si je n'entends pas un clac sec à l'insertion d'une cartouche mvs c'est que c'est mal nettoyé Smile
mes cartouches mvs sont nettoyées à la gomme + essence F

les connecteurs du slot quand j'ai pas d'alcool ipa c'est nettoyé au wd40 classique mrgreen
kazki
kazki
1000 Mega Shock
1000 Mega Shock

Système(s) : AES MVS PGM CPS2 NAOMI
Messages : 5790
Date d'inscription : 22/10/2018

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Jeu 18 Fév 2021 - 20:24

Bilan:

Si j'insert la cartouche a fond j'ai soit crosshatch soit Hardware test Failure Z80 System

Quand je l'insert à mi course, il boot nickel Gné yeux
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  jumpman Jeu 18 Fév 2021 - 21:38

Enskynet a écrit:Cette fois le jeu est un original 100%
Quand je mets la cartouche correctement dans le slot, j'ai un écran Crosshatch ou un bug graphique. Cependant, quand j'insère la cartouche à mi-course uniquement, le jeu fonctionne nickel !! (J'ai eu que 1 seule fois un ecran avec les adresses mémoire en vert sur une session de 1h de jeu. Après redémarrage, nickel).

Pour vous ce symptome est dû à des pistes sales? Je les ai nettoyées avec une gomme blanche et elles sont bien brillantes.
Des pistes fatiguées surtout... C'est d'ailleurs le gros problème du MVS ; l'usure qui commence à se faire ressentir...
jumpman
jumpman
1000 Mega Shock
1000 Mega Shock

Messages : 7774
Date d'inscription : 17/10/2011
Age : 41

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Jeu 18 Fév 2021 - 21:50

Je suis d'accord avec toi et c'est ce que je crains le plus sur le MVS.
Je refuse de laisser ce metal slug mourrir Very Happy

Je vais jouer avec les dip switchs de mon slot, on ne sait jamais (J'ai un slug X qui lui, peut importe si je l'enfonce a fond ou pas, nettoyé a l'iso etc.. ne boot que sur du crosshatch a 100% du temps.)

Pour le slug 3 qui boot 1 fois sur 10 quand je l'enfonce gentiment j'ai testé toutes les continuités, nettoyé les pistes et c'est pareil voir moins bon.
Demain je teste WD 40 / Miror cuivre sur les pistes avant de le mettre de coté pour check les ROM.
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Ven 19 Fév 2021 - 13:31

Petite mise à jour.
J'ai sauvé Metal Slug 3.

Pour le problème de jeu qui ne boot pas quand il est inséré à fond, je pense que c'était bien les contacteurs. Un coup de WD40 + chiffon en frottant bien énergiquement et c'était réglé.

Pour le Z80 Error et les problème de plantage en cours de jeu j'y suis allé par déduction. Et j'ai donc refait 5 ou 6 soudures sur le Neo CMC sur la board CHAFIO + 1 soudure que je trouvais oxydée / sèche sur le A60 et C7.

Le jeu tourne à 100% bien enfoncé dans le slot et après une session de 45 minutes RAS.
Je vais essayer de finir le jeu entièrement pour voir s'il n'y a aucun bug, mais je suis optimiste.

Il me reste le Shock Troopers avec surement la P1 corrompue et le Metal Slug X qui lui reste bloqué en crosshatch constamment => D'ailleurs pour celui la, si quelqu'un en a 1 dans les environs du 95 je paye ma bière à qui fera le geste de me prêter le sien pour que je teste de quelle PCB il s'agit.
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  kazki Ven 19 Fév 2021 - 13:58

Si toi aussi tu as eu le coffret WD40 à la St Valentin

MVS en panne WD-40-Aftershave


Remercie ta chérie car elle vient d’aider à sauver un Slug 3 !!!! mrgreen
kazki
kazki
1000 Mega Shock
1000 Mega Shock

Système(s) : AES MVS PGM CPS2 NAOMI
Messages : 5790
Date d'inscription : 22/10/2018

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Ptchnk Ven 19 Fév 2021 - 14:18

Enskynet a écrit:Il me reste le Shock Troopers avec surement la P1 corrompue et le Metal Slug X qui lui reste bloqué en crosshatch constamment => D'ailleurs pour celui la, si quelqu'un en a 1 dans les environs du 95 je paye ma bière à qui fera le geste de me prêter le sien pour que je teste de quelle PCB il s'agit.

Pour le crosshatch, le pb vient de la PROG. Le MSX à une PROG propre à lui avec un chip Athena qui peut être la source de ton problème.

https://wiki.neogeodev.org/index.php?title=PROGEOP
Ptchnk
Ptchnk
Adepte du stick
Adepte du stick

Système(s) : MVS, Coregrafx, PCE-DUO, RPI2J
Messages : 140
Date d'inscription : 04/05/2020
Age : 42

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Ven 19 Fév 2021 - 14:41

kazki a écrit:Si toi aussi tu as eu le coffret WD40 à la St Valentin

MVS en panne WD-40-Aftershave


Remercie ta chérie car elle vient d’aider à sauver un Slug 3 !!!! mrgreen

A chaque voyage à Action, elle me ramène du WD40 et du nettoyant frein. Indispensables dans le monde de la moto mrgreen

Ptchnk a écrit:
Enskynet a écrit:Il me reste le Shock Troopers avec surement la P1 corrompue et le Metal Slug X qui lui reste bloqué en crosshatch constamment => D'ailleurs pour celui la, si quelqu'un en a 1 dans les environs du 95 je paye ma bière à qui fera le geste de me prêter le sien pour que je teste de quelle PCB il s'agit.

Pour le crosshatch, le pb vient de la PROG. Le MSX à une PROG propre à lui avec un chip Athena qui peut être la source de ton problème.

https://wiki.neogeodev.org/index.php?title=PROGEOP

C'est bien pour cela que j'ai posé la question des jumpers sur ultimate consoles Wink
Je voulais tester des PCB fonctionnels pour être sur que cette panne de puce MAX soit évidente et que je procède à la réparation du PCB en question.
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Ptchnk Ven 19 Fév 2021 - 14:55

C'était toi Smile

Quand j'ai un peu de temps, je regarde pour te filer la config de jumpers qui va bien pour le PROGBK1 pour les roms du MSX si ca t'intéresse.
Ptchnk
Ptchnk
Adepte du stick
Adepte du stick

Système(s) : MVS, Coregrafx, PCE-DUO, RPI2J
Messages : 140
Date d'inscription : 04/05/2020
Age : 42

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Ven 19 Fév 2021 - 15:14

C'est la config qui est décrite dans ce lien : https://wiki.neogeodev.org/index.php?title=Repairing_Metal_Slug_X ??
Si oui, ne t'embête pas je vais suivre ce tuto directement.
Par contre il me faut une BK1 à sacrifier. Et j'ai pas ça en stock.

Si quelqu'un ici a une BK1 en trop mrgreen
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Ptchnk Ven 19 Fév 2021 - 16:03

Yep avec la config du Last Blade, ca le fera. Par contre, il faudra déplacer le jumper de J13 vers J9 car le V3 du MSX est une 16Mo et non une 32Mo. Il te faut bien un progBK1 avec les 3 composants CMS dessus (LS74,LS139 et LS08).

Ptchnk
Ptchnk
Adepte du stick
Adepte du stick

Système(s) : MVS, Coregrafx, PCE-DUO, RPI2J
Messages : 140
Date d'inscription : 04/05/2020
Age : 42

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Ven 19 Fév 2021 - 23:02

Cool, merci de l'info.
Ryo et toi vous êtes calés c'est mortel.

Keep in touch
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Enskynet Mer 24 Fév 2021 - 21:39

En attendant mon programmateur qui est toujours dans l'avion, je suis tombé la dessus:

https://www.ebay.fr/itm/QTY-1-EPM7128SQC100-7-ALTERA-QFP-MAX-7000-CPLD-128-EEPROM-PROGRAMMABLE-LOGIC-NEW-/372411441556

Personne ne sait programmer ça afin que mon MS X reste legit? (Quand je dis personne, je veux plutôt dire est-ce possible?)
Enskynet
Enskynet
Visiteur confirmé
Visiteur confirmé

Messages : 95
Date d'inscription : 30/12/2020

Revenir en haut Aller en bas

MVS en panne Empty Re: MVS en panne

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum