[help audio mvs] certains sons postillonnent sur magicien lord

Aller en bas

[help audio mvs] certains sons postillonnent sur magicien lord

Message  davlar le Dim 25 Nov 2018 - 0:41

Hello les experts du débug hardware,

Je viens d'acquérir un magicien lors mvs, avec un problème de son.

La musique est jouée correctement mais les bruitages des projectiles et les sons de batterie crachent à mort. C'est jouable mais comme si certains sons étaient mal décodés ou parasités. Mais pas tous les sons.

Le jingle NeoGeo au tout début du démarrage est impeccable, le thème de la musique avec les nappes de clavier est nickel, mais la batterie et les projectiles et explosions ne vont pas.

Comment puis je debugger?
j'ai fait un tour à la bino, sans rien voir (quelques doutes sur des pistes, mais c'est bon au ohmmètre).
Pas de soudures sèches, j'ai particulièrement regardé M1, et v11 v21 et v22...

Avez vous d'autres pistes?

En regardant https://wiki.neogeodev.org/index.php?title=Category:Audio_system j'ai eu espoir d'un problème de démultiplicateur avec le 74ls139... Les petites capa peut être, mais ce n'est que du filtrage d'alimentation, non?
avatar
davlar
330 Mega Shock
330 Mega Shock

Système(s) : MV1A; AES 3.6; atomiswave
Messages : 488
Date d'inscription : 29/11/2014
Age : 37
Localisation : Rennes

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  davlar le Dim 25 Nov 2018 - 0:57

Sur cet article https://forum.arcadeotaku.com/viewtopic.php?t=32424&start=20#p443581  on parle d'eprom trop lente.
Et en regardant les pcb, j'ai des références  différentes que celles sur mvs scan.

J'ai un set 2 mais les valeurs z01, r01 z00 ne sont pas les mêmes.
Mes PCS ne présentent pas de traces de réparations ou soudure manuel...
avatar
davlar
330 Mega Shock
330 Mega Shock

Système(s) : MV1A; AES 3.6; atomiswave
Messages : 488
Date d'inscription : 29/11/2014
Age : 37
Localisation : Rennes

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  onels4 le Dim 25 Nov 2018 - 8:28

Bonjour, j'ai eu le cas sur un autre jeu et on m'a parlé de réglages DIP switchs pour les MVS. Ca remonte à loin donc je ne peux pas vraiment t'en dire plus mais il y a peut-être une piste à explorer.

Ton jeu a l'air en bon état.

_________________
Si les poules pondaient des jeux AES, je serais éleveur.
=> Mes ventes AES.
=> Vente multimètres pro Fluke & Keysight.
avatar
onels4
Combo maker
Combo maker

Système(s) : AES
Messages : 943
Date d'inscription : 27/06/2017
Age : 37
Localisation : Paris

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  davlar le Dim 25 Nov 2018 - 8:56

Salut Onels4, merci pour ta réponse, ça me fait pensé à la méthode de Nico pour lutter contre les backup ram error, ici mon slot fonctionne très bien avec tous les autres jeux, et le ML était vendu avec ce bug... J'ai peur de corruption de la ROM M1 ou les Vx qui ont les échantillons, c'est bien ça ? Sinon il est nickel c'est vrai Very Happy
avatar
davlar
330 Mega Shock
330 Mega Shock

Système(s) : MV1A; AES 3.6; atomiswave
Messages : 488
Date d'inscription : 29/11/2014
Age : 37
Localisation : Rennes

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  davlar le Dim 25 Nov 2018 - 23:48

davlar a écrit:...
J'ai un set 2 mais les valeurs z01, r01 z00 ne sont pas les mêmes.
Mes PCS ne présentent pas de traces de réparations ou soudure manuel...

Je relis un topic du forum, ce jeu est un set 1 en fait si je crois la description suivante:

"Le set 1 est celui où l'on a 4 points de vie au maximum et où l'on respawn à l'endroit où on est mort."
http://www.neogeo-system.com/t3649p100-quelle-version-aes-de-magician-lord-possedez-vous#222450

Mais par rapport aux MVS scan, j'ai un set 2 du set 1 (truc de cinglé...), avec des marquage d'eprom différent de la photo.
Vous avez l'antibrouillard sur les MVS magician lord?
avatar
davlar
330 Mega Shock
330 Mega Shock

Système(s) : MV1A; AES 3.6; atomiswave
Messages : 488
Date d'inscription : 29/11/2014
Age : 37
Localisation : Rennes

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  Ryo Sakazaki le Dim 25 Nov 2018 - 23:53

davlar a écrit:
Mais par rapport aux MVS scan, j'ai un set 2 du set 1 (truc de cinglé...), avec des marquage d'eprom différent de la photo.
Vous avez l'antibrouillard sur les MVS magician lord?

De quel marquage différent tu parles davlar stp ?

As tu des photos pour étayer ?

_________________

_________________


Administrateur sur Neo-Geo System

Je réalise des converts AES/MVS, programmation d'eproms, bios, etc...
avatar
Ryo Sakazaki
Admin

Système(s) : AES Jap, MVS MV-2F
Messages : 12851
Date d'inscription : 15/10/2011
Age : 43
Localisation : Dept 91

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  davlar le Lun 26 Nov 2018 - 1:07

Oui j'ai mis une photo plus haut, quand je compare aux photos sur MVS scan, j'ai le tableau suivant:
http://www.mvs-scans.com/index.php/File:Magician_lord_set2_b2_front.jpg

| EPROM  | moi | mvs scan Board Scans - Set 2 |
| 005-C2 | Z02  |Z00                                       |
| 005-C4 | Z00  |Z02                                       |
| 005-C6 | Z01  |Z02                                       |
| 005-C5 | Z01  | Z01                                      |
| 005-C3 | Z00  | Z01                                      |
| 005-C1 | Z00  | Z01                                      |
| 005-M1 | R01  |R02                                       |
| 005-S1 | Z01  | Z01                                      |

Est-ce que le Z reprevente des caracteristiques des eprom, comme la vitesse d'accès?


En lisant des infos sur neogeodev je pense qu'en installant l'unibios, je pourrai utiliser le juke box pour voir préciséement les son qui merdent... est-ce que ça m'aiderait à comprendre?
(info audio: audio diagram)

La boot music est bien rendue, elle est jouée par le "module" FM : boot music
avatar
davlar
330 Mega Shock
330 Mega Shock

Système(s) : MV1A; AES 3.6; atomiswave
Messages : 488
Date d'inscription : 29/11/2014
Age : 37
Localisation : Rennes

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  nic034 le Lun 26 Nov 2018 - 18:59

Salut,

Nettoie le connecteur de ta cartouche dans un premier temps, grosse blanche sur les 2 pub + essence-f.
Sur mon convert MVS de windjammers, j'ai du faire une modification en ajoutant des condensateurs céramiques pour éviter ce genre de saturation..
http://www.neogeo-system.com/t6458-tuto-corriger-problemes-de-pcm-bruitages-satures-sur-conversion-mvs-mvs-ou-autres

C'est quand même généralement soit un problème de contact, soit un reflow à faire sur tes eeproms.
Un peu de taf en somme

A+
avatar
nic034
1000 Mega Shock
1000 Mega Shock

Système(s) : MVS
Messages : 1165
Date d'inscription : 03/01/2016
Age : 40
Localisation : Montpellier

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  davlar le Lun 26 Nov 2018 - 21:51

Salut Nico, merci pour ta réponse, le symptôme semble bien identique.
Of course , j'ai commencé par nettoyer les connecteurs à l'essence f + gommage, mais aucune amélioration, sans surprise. Je suis bluffé par le coup du filtrage supplémentaire... Le jeu a du fonctionner sans, il est original de chez original, pourquoi il merde.maintenant...

Je note ton conseil pour refaire les soudures, mais sur quels chip? Les epprom ou le Ski Pcm( je m'en vais regarder où il est placé sur neogeodev...

Merci pour les conseils et le retour d'experiences, vraiment sympa!
avatar
davlar
330 Mega Shock
330 Mega Shock

Système(s) : MV1A; AES 3.6; atomiswave
Messages : 488
Date d'inscription : 29/11/2014
Age : 37
Localisation : Rennes

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  Ryo Sakazaki le Lun 26 Nov 2018 - 23:13

Je crois pas trop à une soudure car en plus ceux sont des doubles soudures donc bien chiante pour en enlever une et la contrôler sur un programmateur. silent

_________________

_________________


Administrateur sur Neo-Geo System

Je réalise des converts AES/MVS, programmation d'eproms, bios, etc...
avatar
Ryo Sakazaki
Admin

Système(s) : AES Jap, MVS MV-2F
Messages : 12851
Date d'inscription : 15/10/2011
Age : 43
Localisation : Dept 91

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  nic034 le Mer 28 Nov 2018 - 21:02

+1 avec Ryo en effet, essaye le coup du filtrage additionnel, peut être une surtension/parasites sur une des lignes en sortie de la cartouche ?

Nico
avatar
nic034
1000 Mega Shock
1000 Mega Shock

Système(s) : MVS
Messages : 1165
Date d'inscription : 03/01/2016
Age : 40
Localisation : Montpellier

Revenir en haut Aller en bas

Re: [help audio mvs] certains sons postillonnent sur magicien lord

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum